Resolving the Requirement.parse(‘toml==0.9.3.1’) conflict in Steempy

The environment used in this example is Debian Sid with Python 3.6 and steem-0.18.103

Within your user’s home directory, navigate to:

.local/lib/python.36/site-packages/steem-0.18.103.dist-info

 

Edit the METADATA file using your favorite text editor:

nano METADATA

Navigate to:

Requires-Dist: toml (==0.9.3.1)

…and change it to:

Requires-Dist: toml (==0.9.3)

This should allow your Steempy script to run with the toml package version being off by one decimal point

Leave a Reply

Your email address will not be published. Required fields are marked *