Resolving steembase.storage.WrongMasterPasswordException When trying to import wallet

Note: This guide is using Debian Sid with Python 3.6

What may assumed in this situation:

  • You have forgotten your password
  • The Steem wallet’s database has been corrupted
  • You hare using some strange character’s within your password (some have reported having issues with ‘^’)

In any event, it will be best ro reset everything withn your Steem’s database and start from scratch if you cannot log into your wallet.

To do so, start by removing to your wallet’s database file in your home directory:

rm ~/.local/share/steem/steem.sqlite

Now to set a new password, you will need to trigger an event to create a new password as if you were starting from scratch. One example would be the ‘changewalletpassphrase’ argument:

:~/ python3 steempy changewalletpassphrase

:~/ Passphrase:

:~/ Please provide the new password

:~/ Passphrase:

:~/ Confirm Passphrase:

Be sure to enter the same password in all three Passphrase prompts in the example above.

Resolving URLLB3 Errors in SteemPy

If you are like me and trying to get the official Pip version of steem to run on Debian Sid, you may have your terminal spammed with this message:

File “/home/user/.local/lib/python3.6/site-packages/urllib3/connection.py”, line 141, in _new_conn

What is unfortunate is that this relatively common error is never mentioned within official Steempy installation guides at the top of Google’s results page.

What is fortunate is that there is a quick fix. Simply run:

:~/ steempy set nodes https://api.steemit.com

That’s all there is to it. You should no longer get connection error messages from urllib3.

Resolving the Requirement.parse(‘toml==0.9.3.1’) conflict in Steempy

The environment used in this example is Debian Sid with Python 3.6 and steem-0.18.103

Within your user’s home directory, navigate to:

.local/lib/python.36/site-packages/steem-0.18.103.dist-info

 

Edit the METADATA file using your favorite text editor:

nano METADATA

Navigate to:

Requires-Dist: toml (==0.9.3.1)

…and change it to:

Requires-Dist: toml (==0.9.3)

This should allow your Steempy script to run with the toml package version being off by one decimal point